• «
  • 1
  • 2
  • 3
  • »
  • Pages: 1/3     Go
主题 : 64位win7下面usb 下载线驱动的一种解决方法实践 复制链接 | 浏览器收藏 | 打印
级别: 新手上路
UID: 44787
精华: 0
发帖: 29
金钱: 145 两
威望: 29 点
贡献值: 0 点
综合积分: 58 分
注册时间: 2011-04-28
最后登录: 2015-12-13
楼主  发表于: 2012-06-10 01:42

 64位win7下面usb 下载线驱动的一种解决方法实践

在64位机器下面,装s3c6410的usb下载线的驱动,目前为止是没有任何办法的。国外有一个小组开发了mini2410的64位驱动,但是,装载了之后不能对s3c6410工作,并且那个自带的程序仅仅针对mini2410,写的地址固定在3000000,没有办法改动。
目前,除了重新装回xp系统以外,似乎没有好的办法了。但是,真是舍不得自己原装笔记本格式化回去xp,那么,可以用虚拟机试一试。
我尽量说的详细一些,因为这个论坛不知道怎么发图。

在虚拟机上装载了xp以后,把鼠标放在虚拟机里面。然后,首先插上usb下载线,提示发现新硬件,用友善提供的光盘驱动装载,成功。 然后,插上usb转串口线,在硬件管理那个地方找到串口号码,装驱动。成功。

实验打开secureCRT,把6410板子开关打到sd卡启动,开电源,从secureCRT上读出信息。选择d, 然后打开DNW,看到usb 是ok状态。选择友善的demo,这时候从CRT上打印出来:
hello, mini6410。

至此,完成了不用总是插、拔出sd卡,而可以进行裸机程序开发的操作。

如何制作superboot在sd卡上。注意几点:
从手册上读到的是BIOS装载到SD卡上,就是superboot这个东西了。在win7上,一定,一定,一定要选择用管理员身份打开s-flash那个程序,不然一定出错。 还有就是格式化sd卡为fat32格式。手册上说不一定成功。如果严格按照上述步骤,是保证成功的。

我用的SD,不是SDHC那种好一点的,2G的老卡,一次成功。

这只是一种方法而已。我想现在的64win7都已经成为主流了,希望友善能够提供完整的驱动让大家使用。我从昨天后半夜折腾了近12个小时才搞定这个流程,相当的没有成就感。希望给大家一个方法试试看。
级别: 新手上路
UID: 44539
精华: 0
发帖: 21
金钱: 105 两
威望: 21 点
贡献值: 0 点
综合积分: 42 分
注册时间: 2011-04-26
最后登录: 2017-06-19
1楼  发表于: 2012-07-07 23:17
虚拟机很麻烦啊!!!
级别: 新手上路
UID: 73184
精华: 0
发帖: 44
金钱: 220 两
威望: 44 点
贡献值: 0 点
综合积分: 88 分
注册时间: 2012-07-04
最后登录: 2013-05-28
2楼  发表于: 2012-07-08 09:37
正在搞USB-串口驱动。。。
64位win7中。。。
级别: 新手上路
UID: 73184
精华: 0
发帖: 44
金钱: 220 两
威望: 44 点
贡献值: 0 点
综合积分: 88 分
注册时间: 2012-07-04
最后登录: 2013-05-28
3楼  发表于: 2012-07-08 20:37
我今天试了下这个方法。。。。
在虚拟机里的串口调试工具,超级终端和CRT都有一个问题:

开机后有提示选项,
不过选完之后没有相应的内容反馈。
比如我按v,就没有提示等待download的 image。。。


纠结中。。。不想做系统。。。我的superboot 还启动不了板子。。。果断悲剧了
级别: 新手上路
UID: 51032
精华: 0
发帖: 26
金钱: 135 两
威望: 27 点
贡献值: 0 点
综合积分: 52 分
注册时间: 2011-06-28
最后登录: 2012-11-22
4楼  发表于: 2012-09-13 13:41
我用友善提供的usb下载驱动装在在64位win7上,好像没有反应,dnw上显示usb还是个"X",至今不知道用什么办法
级别: 新手上路
UID: 70943
精华: 0
发帖: 15
金钱: 75 两
威望: 15 点
贡献值: 0 点
综合积分: 30 分
注册时间: 2012-05-28
最后登录: 2013-03-27
5楼  发表于: 2012-09-20 16:24
尽快完善吧~~我现在在试着用ubuntu做开发~
级别: 新手上路
UID: 81424
精华: 0
发帖: 1
金钱: 5 两
威望: 1 点
贡献值: 0 点
综合积分: 2 分
注册时间: 2012-11-08
最后登录: 2012-11-19
6楼  发表于: 2012-11-19 20:20

 回 楼主(hudie75) 的帖子

用虚拟机的时候我出现一个问题(WIN7(64位)宿主机,虚拟机里装XP),虚拟机里只能识别WIN7能识别的设备(像U盘、串口),对WIN7不能识别的设备,没有反应,不知道你有没有出现过这种情况?(虚拟机是VMware-8.0.4)
级别: 新手上路
UID: 65309
精华: 0
发帖: 14
金钱: 70 两
威望: 14 点
贡献值: 0 点
综合积分: 28 分
注册时间: 2012-03-16
最后登录: 2017-09-13
7楼  发表于: 2012-11-24 09:26
这个可以用 已经用win7-64位旗舰版试验
http://hi.baidu.com/ruiwelcome/item/139c993e5b553bca1b9696f4
级别: 新手上路
UID: 80511
精华: 0
发帖: 46
金钱: 235 两
威望: 47 点
贡献值: 0 点
综合积分: 92 分
注册时间: 2012-10-26
最后登录: 2014-08-27
8楼  发表于: 2012-11-24 18:32

 回 7楼(ruiwelcome) 的帖子

我有驱动,可以联系我
级别: 新手上路
UID: 82965
精华: 0
发帖: 4
金钱: 25 两
威望: 5 点
贡献值: 0 点
综合积分: 8 分
注册时间: 2012-11-30
最后登录: 2013-09-06
9楼  发表于: 2012-11-30 12:50

 回 7楼(ruiwelcome) 的帖子

这个不行啊,第一次是好的,如果关闭arm的电源再打开,win7就蓝屏了。
  • «
  • 1
  • 2
  • 3
  • »
  • Pages: 1/3     Go