• «
  • 1
  • 2
  • 3
  • »
  • Pages: 1/3     Go
主题 : Linux 2.6.3x内核中的mini2440支持(was:请问是不是linux2.6.32及其之后的内核...) 复制链接 | 浏览器收藏 | 打印
100
级别: 新手上路
UID: 3757
精华: 0
发帖: 9
金钱: 50 两
威望: 18 点
贡献值: 0 点
综合积分: 18 分
注册时间: 2009-02-06
最后登录: 2012-03-11
楼主  发表于: 2010-03-20 23:37

 Linux 2.6.3x内核中的mini2440支持(was:请问是不是linux2.6.32及其之后的内核...)

管理提醒: 本帖被 kasim 从 micro2440技术交流专区 移动到本区(2010-03-21)
听说linux内核新加入了对mini2440的支持,那么是不是意味着,linux2.6.32及其之后的内核版本都可以不经任何修改直接跑在mini2440上呢?谢谢。
[ 此帖被kasim在2010-03-21 07:01重新编辑 ]
*無鈳取玳
级别: 论坛版主
UID: 27
精华: 12
发帖: 5407
金钱: 40120 两
威望: 17929 点
贡献值: 71 点
综合积分: 11054 分
注册时间: 2008-01-16
最后登录: 2014-11-22
1楼  发表于: 2010-03-21 06:56
是的,理论上是这样;
但实际上,由于mini2440的内核维护者在提交mini2440部分代码时并不是基于最终发布版本的code base,因此可能会出现一些问题。
参考下面的帖子:
http://arm9home.net/read.php?tid-3228.html

这是mini2440内核维护者目前维护mini2440所设立的项目:
http://code.google.com/p/mini2440/

这是mini2440的源代码仓库:
U-Boot:http://repo.or.cz/w/u-boot-openmoko/mini2440.git
内核: http://repo.or.cz/w/linux-2.6/mini2440.git
文件系统整合: http://repo.or.cz/w/openembedded/mini2440.git
QEMU for mini2440: http://repo.or.cz/w/qemu/mini2440.git (一个非常有用的mini2440模拟器,可以直接将交叉编译后的代码运行在上面)

这是他的博客,上面有对mini2440代码最新的更新信息。(已经被和谐,需要代理服务器)
http://bliterness.blogspot.com/
[ 此帖被kasim在2010-03-21 07:01重新编辑 ]
"If you have an apple and I have an apple and we exchange apples, then you and I will
still each have one apple. But if you have an idea and I have an idea and we exchange
these ideas, then each of us will have two ideas."
*無鈳取玳
级别: 论坛版主
UID: 27
精华: 12
发帖: 5407
金钱: 40120 两
威望: 17929 点
贡献值: 71 点
综合积分: 11054 分
注册时间: 2008-01-16
最后登录: 2014-11-22
2楼  发表于: 2010-03-21 07:19
刚开设了mini2440邮件列表,大家可以直接发邮件到mini2440@googlegroups.com,询问有关mini2440的问题(最好是用英文,mini2440的维护者是老外)
"If you have an apple and I have an apple and we exchange apples, then you and I will
still each have one apple. But if you have an idea and I have an idea and we exchange
these ideas, then each of us will have two ideas."
100
级别: 新手上路
UID: 3757
精华: 0
发帖: 9
金钱: 50 两
威望: 18 点
贡献值: 0 点
综合积分: 18 分
注册时间: 2009-02-06
最后登录: 2012-03-11
3楼  发表于: 2010-03-22 23:45
非常感谢版主的解答!!
级别: 新手上路
UID: 20071
精华: 0
发帖: 1
金钱: 5 两
威望: 1 点
贡献值: 0 点
综合积分: 2 分
注册时间: 2010-04-26
最后登录: 2010-04-26
4楼  发表于: 2010-04-26 22:29
mini2440  是不是要求 LINUX 内核要在2.6呢?
*無鈳取玳
级别: 论坛版主
UID: 27
精华: 12
发帖: 5407
金钱: 40120 两
威望: 17929 点
贡献值: 71 点
综合积分: 11054 分
注册时间: 2008-01-16
最后登录: 2014-11-22
5楼  发表于: 2010-04-26 22:56

 回 4楼(heping762825) 的帖子

不是,但问题是,你现在还去用2.4的内核,有意义吗?
"If you have an apple and I have an apple and we exchange apples, then you and I will
still each have one apple. But if you have an idea and I have an idea and we exchange
these ideas, then each of us will have two ideas."
级别: 新手上路
UID: 22727
精华: 0
发帖: 25
金钱: 125 两
威望: 25 点
贡献值: 0 点
综合积分: 50 分
注册时间: 2010-06-06
最后登录: 2010-12-07
6楼  发表于: 2010-07-04 12:22
我前天试了下2.6.34
好像网卡驱动还是有点问题,得修改一下。
等段时间再试试。
自己编译的busybox太新了,友善自己的那个内核启动不起来(自己修改过分区的了)。
级别: 新手上路
UID: 22727
精华: 0
发帖: 25
金钱: 125 两
威望: 25 点
贡献值: 0 点
综合积分: 50 分
注册时间: 2010-06-06
最后登录: 2010-12-07
7楼  发表于: 2010-07-05 12:00
昨天晚上简单地按照网上的补丁修改了一下d9000的驱动,编译好就可以启动了。
不过自己弄的busybox还有点问题,还得再试试

引用第6楼tjpm于2010-07-04 12:22发表的  :
我前天试了下2.6.34
好像网卡驱动还是有点问题,得修改一下。
等段时间再试试。
自己编译的busybox太新了,友善自己的那个内核启动不起来(自己修改过分区的了)。
级别: 新手上路
UID: 20192
精华: 0
发帖: 7
金钱: 35 两
威望: 7 点
贡献值: 0 点
综合积分: 14 分
注册时间: 2010-04-28
最后登录: 2010-09-24
8楼  发表于: 2010-09-21 14:12
mark一下
不再无聊
级别: 新手上路
UID: 33262
精华: 0
发帖: 16
金钱: 90 两
威望: 18 点
贡献值: 0 点
综合积分: 32 分
注册时间: 2010-11-28
最后登录: 2012-05-09
9楼  发表于: 2010-12-02 22:20
如何编译一个可以在s3c2440上运行的linux内核,讲下具体步骤
  • «
  • 1
  • 2
  • 3
  • »
  • Pages: 1/3     Go