主题 : NanoPi NEO 的 Python3.8 上安装 PyQt5 复制链接 | 浏览器收藏 | 打印
级别: 新手上路
UID: 146580
精华: 0
发帖: 1
金钱: 5 两
威望: 1 点
贡献值: 0 点
综合积分: 2 分
注册时间: 2021-08-14
最后登录: 2021-08-14
楼主  发表于: 36天前

 NanoPi NEO 的 Python3.8 上安装 PyQt5

NanoPi NEO 官方操作系统基于的是 Ubuntu16,自带的 Python 版本是 3.5 版本。因为系统自带的 Python 版本太低,很多模块都没法正常使用,所以需要使用更新版本的 Python。
我用源码编译的方法安装上了 Python3.8,但是使用 Python3.8 的 pip 安装 PyQt5 时会报错。
如果使用 apt 安装 python3-pyqt5,实际上是安装在了系统自带的 Python3.5 里面,Python3.8 是没有 PyQt5 的。
也试过把 Python3.8 设置成系统默认的 Python,但是 apt 安装 python3-qpyt5 时报了二进制不支持的错。
不知各位大佬是否还有其他思路可以在新版本的 Python 中安装上 PyQt5 的,十分感谢呀