• «
  • 1
  • 2
  • 3
  • »
  • Pages: 1/3     Go
主题 : Qt5交叉编译移植新手指南 复制链接 | 浏览器收藏 | 打印
QQ群 嵌入式之家西安群1(172531658)嵌入式之家群1(41422269)http://www.cmeee.com/
级别: 侠客
UID: 15142
精华: 1
发帖: 40
金钱: 250 两
威望: 50 点
贡献值: 1 点
综合积分: 100 分
注册时间: 2010-03-01
最后登录: 2017-08-16
楼主  发表于: 2013-11-19 14:43

 Qt5交叉编译移植新手指南

管理提醒: 本帖被 xoom 执行提前操作(2013-11-20)
开始
首先我们先创建一个目录来存放Qt5的源代码以及交叉编译所需要的所有文件,我选择在当前用户家目录下创建一个叫做“opt”的目录。
1    diveinedu@debian:~$ mkdir  ~/opt
2    diveinedu@debian:~$ cd  ~/opt

然后,下载以下文件:

下载Raspbian Wheezy 镜像  (这里下载 [raspberrypi.org]):
1    diveinedu@debian:~/opt$ wget  downloads.raspberrypi.org/images/raspbia...-wheezy-raspbian.zip
2    diveinedu@debian:~/opt$unzip  2013-02-09-wheezy-raspbian.zip

下载解压完后挂载镜像:
1    diveinedu@debian:~/opt$ sudo  mkdir  /mnt/rasp-pi-rootfs
2    diveinedu@debian:~/opt$ sudo mount  -o loop,offset=62914560 2013-03-09-wheezy-raspbian.img    /mnt/rasp-pi-rootfs

我们这不介绍交叉工具链的编译,直接下载针对树莓派优化定制的交叉编译工具链(或者用github上树莓派的工具链https://github.com/raspberrypi/tools):
1    diveinedu@debian:~/opt$  wget  blueocean.qmh-project.org/gcc-4.7-linaro-rpi-gnueabihf.tbz
2    diveinedu@debian:~/opt$   tar -xf gcc-4.7-linaro-rpi-gnueabihf.tbz

因为上面的交叉编译工具是32位Linux的,如果你所使用的是64位Linux的话,还需要安装32位的运行库软件包:
1    diveinedu@debian:~/opt$  sudo apt-get install ia32-libs

如果用的是Debian Wheezy的64位系统,上面的行不通,因为Debian Wheezy 64位开启了multiarch-support ,需要执行:
1    diveinedu@debian:~/opt$  sudo apt-get install multiarch-support
2    diveinedu@debian:~/opt$  sudo dpkg --add-architecture i386
3    diveinedu@debian:~/opt$  sudo apt-get update
4    diveinedu@debian:~/opt$  sudo apt-get install ia32-libs



从远程仓库克隆一份cross-compile-tools到本地:
1    diveinedu@debian:~/opt$  git clone git://gitorious.org/cross-compile-tools/cross-compile-tools.git

从远程仓库克隆一份Qt5的源码库到本地:
1    diveinedu@debian:~/opt$  git clone git://gitorious.org/qt/qt5.git
2    diveinedu@debian:~/opt$   cd qt5
3    diveinedu@debian:~/opt/qt5$  ./init-repository

最后,把qtjsbackend子项目打补丁让其支持armv6指令集的树莓派:
1    diveinedu@debian:~/opt/qt5$  cd ~/opt/qt5/qtjsbackend
2    diveinedu@debian:~/opt/qt5$  git fetch codereview.qt-project.org/p/qt/qtjsbackend  refs/changes/56/27256/4   &&   git  cherry-pick  FETCH_HEAD

如果有冲突的话就解决冲突的代码。




编译qtbase
现在我们已经准备好了为树莓派交叉编译Qt5所需要的全部资源,在正式编译之前只需要执行一个小脚本来修正一下符号链接和库文件路径设置:
1    diveinedu@debian:~/opt/qt5$  cd  ~/opt/cross-compile-tools
2    diveinedu@debian:~/opt/qt5$  sudo  ./fixQualifiedLibraryPaths/mnt/rasp-pi-rootfs/~/opt/gcc-4.7-linaro-rpi-gnueabihf/bin/arm-linux-gnueabihf-gcc

进入qt5/qtbase目录执行以下脚本进行配置和编译工作:
1    diveinedu@debian:~/opt/qt5$ cd ~/opt/qt5/qtbase
2    diveinedu@debian:~/opt/qt5/qtbase$ ./configure -opengl es2 -devicelinux-rasp-pi-g++ -device-optionCROSS_COMPILE=~/opt/gcc-4.7-linaro-rpi-gnueabihf/bin/arm-linux-gnueabihf--sysroot /mnt/rasp-pi-rootfs -opensource -confirm-license-optimized-qmake -reduce-relocatio n s -reduce-exports -release -make libs-prefix /usr/local/qt5pi -no-pch
3    diveinedu@debian:~/opt/qt5/qtbase$ make -j 4
4    diveinedu@debian:~/opt/qt5/qtbase$ sudo make install


编译其他模块
执行到这步的时候,你已经有了针对树莓派交叉编译的qmake工具了,你可以一一的去交叉编译Qt5的其他模块了,为里避免模
块编译过程中可能出现的依赖错误, 建议按照这个模块顺序去编译: qtimageformats, qtsvg, qtjsbackend, qtscript,qtxmlpatterns, qtdeclarative, qtsensors, qt3d,qtgraphicaleffects,qtjsondb,qtlocation, qtdocgallery.
模块编译相关的类似命令:
1    diveinedu@debian:~/opt/qt5$ cd qtimageformats
2    diveinedu@debian:~/opt/qt5/qtimageformats$ /usr/local/qt5pi/bin/qmake .
3    diveinedu@debian:~/opt/qt5/qtimageformats$ make -j4
4    diveinedu@debian:~/opt/qt5/qtimageformats$ sudo make install

把你所需要或者所想编译的模块都按顺序执行编译安装命令后,所有需要的东西都安装在了镜像文件(raspbain wheezy image)里面了。我们接下来就是把他烧到SD卡上去。 SD卡烧写命令:
1    diveinedu@debian:~/opt/qt5$ cd ~/opt/
2    diveinedu@debian:~/opt$ sync; sudo umount /mnt/rasp-pi-rootfs
3    diveinedu@debian:~/opt$ sudo dd bs=1M if=2013-02-09-wheezy-raspbian.img of=/dev/sdc; sync

提示:/dev/sdc是我使用的SD的设备, 请根据自己的实际情况修改。



到这里,Qt5运行库的编译移植过程就Done了。

更多。。。
级别: 禁止发言
UID: 94455
精华: 0
发帖: 56
金钱: 295 两
威望: 59 点
贡献值: 0 点
综合积分: 112 分
注册时间: 2013-07-17
最后登录: 2014-07-24
1楼  发表于: 2013-12-03 15:21
用户被禁言,该主题自动屏蔽!
级别: 新手上路
UID: 95089
精华: 0
发帖: 15
金钱: 75 两
威望: 15 点
贡献值: 0 点
综合积分: 30 分
注册时间: 2013-08-02
最后登录: 2014-07-20
2楼  发表于: 2014-07-20 21:29
顶友善,看看这款友善的杰作,友善全国开发板No.1 比起那种抄板的,您更相信谁呢,当然是友善之臂,全国开发板领头羊.
级别: 新手上路
UID: 64736
精华: 0
发帖: 7
金钱: 35 两
威望: 7 点
贡献值: 0 点
综合积分: 14 分
注册时间: 2012-03-09
最后登录: 2017-09-13
3楼  发表于: 2014-09-26 12:10
QT5怎么支持中文呢?
级别: 侠客
UID: 401
精华: 0
发帖: 77
金钱: 470 两
威望: 190 点
贡献值: 0 点
综合积分: 154 分
注册时间: 2008-03-27
最后登录: 2017-07-24
4楼  发表于: 2014-11-24 10:46
级别: 新手上路
UID: 15314
精华: 0
发帖: 27
金钱: 135 两
威望: 27 点
贡献值: 0 点
综合积分: 54 分
注册时间: 2010-03-03
最后登录: 2015-05-04
5楼  发表于: 2015-01-15 15:06
学习。。。。。借鉴。。。。。。。。。。。。
级别: 侠客
UID: 14619
精华: 0
发帖: 98
金钱: 490 两
威望: 98 点
贡献值: 0 点
综合积分: 196 分
注册时间: 2010-02-17
最后登录: 2016-07-15
6楼  发表于: 2015-04-21 12:32
很给力,10个赞
jacky
天天酷跑,酷跑天天
级别: 侠客
UID: 96347
精华: 0
发帖: 61
金钱: 305 两
威望: 61 点
贡献值: 0 点
综合积分: 122 分
注册时间: 2013-09-12
最后登录: 2016-03-04
7楼  发表于: 2015-07-31 09:54
谢谢楼主分享
级别: 新手上路
UID: 97913
精华: 0
发帖: 33
金钱: 165 两
威望: 33 点
贡献值: 0 点
综合积分: 66 分
注册时间: 2013-11-09
最后登录: 2016-12-29
8楼  发表于: 2015-10-22 14:36
请问QT5可以支持多点触摸吗?

QT4用了TSLIB是只支持单点触摸的

现在我要做QT,而且是支持多点触摸的,请问QT5能实现吗?
级别: 新手上路
UID: 97913
精华: 0
发帖: 33
金钱: 165 两
威望: 33 点
贡献值: 0 点
综合积分: 66 分
注册时间: 2013-11-09
最后登录: 2016-12-29
9楼  发表于: 2015-10-22 14:37
QT4用了TSLIB是只支持单点触摸的,

现在我要做QT,而且是支持多点触摸的,请问QT5能实现吗?
  • «
  • 1
  • 2
  • 3
  • »
  • Pages: 1/3     Go